I had to downgrade gradle to 4.7 to get Step 4. without an error:

Changed the last line in the file, gradle-wrapper.properties

#Thu Feb 07 13:03:31 EST 2019
distributionBase=GRADLE_USER_HOME
distributionPath=wrapper/dists
zipStoreBase=GRADLE_USER_HOME
zipStorePath=wrapper/dists
distributionUrl=https\://services.gradle.org/distributions/gradle-4.7-all.zip

Turned to this Github issue for the solution:

Unable to load class ‘org.gradle.api.publish.ivy.internal.artifact.DefaultIvyArtifact

Freelance Developer